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Why base Web Part?

When I started working with Web Parts the first thing that I really missed was a possibility to work with Web
Parts the way I worked with ASP.NET web pages and web user controls. In other words, I missed the ability
to separate design/layout of Web Part from the "code behind" or business logic. Beside the fact that design
is not separated from code behind I really didn't like the fact that I had to spend a lot of time writing
everything manually.

The solution

Some time ago I read a great article made by Michiel Van Otegem about skinned controls
(http://www.code-magazine.com/article.aspx?quickid=0401051&page=1). Based on his idea and based on
functionality of his SkinnedPart I made BaseSkinnedWebPart which is slightly improved Michiel's control.
Beside that I created a console application that generates Web Parts based on already made skins (ASCX
controls).

Another advantage of using the base class and swpgen is the fact you can create multiple skins (ASCX)
controls and choose different look for your Web Parts at runtime.

Using BaseSkinnedWebPart and swpgen.exe (generator tool) developers can work with web parts almost
the same way they work with web pages and web user controls. Base idea is as follows (more details
explanation will follow below):

1. Create an ASCX control without code behind (just ASCX file with ASP.NET controls and other
HTML)

2. Use swpgen.exe to generate class that inherits from BaseSkinnedWebPart and uses previously
made ASCX control (skin)

3. Add generated classes to a Web Parts project and add additional functionality the same way you
would work with a regular web page.

A practical example

I'll show here all the steps one should take in order to make a fully functional Web Part leveraging the
functionalities of BaseSkinnedWebPart and using the swpgen generator tool.

Part 1 - Creating initial skins
In Part 1 I'll cover the creation of initial skin. Here are the steps that one could perform:

1. Create initial solution
a. Open VisualStudio (I used version 2005 with SP1 in this example)
b. Select File > New - Project from main menu
¢. Expand the “Other Project Types” node in “Project types:” section
d. Click on “Visual Studio Solutions” node below “Other Project Types” node
e. Click on “Blank Solution” node in “Templates” section (on right side)

Aditasor

f.  Enter “Name" and “Location” for new solution and click OK



2. Add a Web Application Project that will hold skins
a. Right click on solution in “Solution Explorer”
b. Choose "Add” = “New Project...”
c. Click on “Visual C#" in "Project types:” section
d. Select ASP.NET Web Application in “Templates” section (on right side)
e

Enter “Name” and “Location” for your new Web Application project
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A project for creating an application with a Web user interface

Name: SampleSkinns

Location: C\MyProjects\samples\SampleBaseSkinnedWebPart

f.  Click OK button
3. Remove unnecessary items
a. Select Default.aspx and Web.config files
b. Right click on selection and choose “Delete” menu item
¢.  Confirm that you want to delete selected items
4. Create initial skins folder structure
NB: in this sample I planned to have to have two themes/skins for my web part. Depending on
number of skins you want for your web parts you can make a slightly different configuration. You
can also change this later if you want or if you need to add new skins.
a. Right click on your Web Application project in Solution Explorer
b. Choose “"Add"” > “New Folder”
¢.  Name first folder "default”
d. Repeat steps a. to c. to create another folder named "theme2”
5. Add new “skins”
a. Right click the "default” folder in your Web Application’s project
Choose "Add” = “New Item..."
Select "Web User Control” in “Templates” section

a0 o

Enter name for your first skin; NB: I suggest you name skin the same way you will name
your Web Part (just with extension ASCX instead of CS)
e. Click "Add”

Add New ltem - SampleSans

N SampleWebPartascx



f.  Right click on “theme2” folder and repeat steps b. to e. (you can give the same name to
skins in both folders)
6. Remove code-behind files
a. Expand both folder's nodes
b. Expand both ASCX control's nodes

c.  Select ".ascx.cs” and “.ascx.designer.cs” files for first skin
[ Selution 'SampleBaseSkinnedWebPart' (1 project)
=2 _% SampleSkinns
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|-3] References
= |7 default
=] SampleWebPart.ascx
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d. Right click on selection and choose “Delete” menu item

e. Confirm that you want to delete selected items permanently

f.  Repeat steps c. to e. for the second skin (in “theme2” folder)

7. Design your skins

a. Double click “SampleWebPart.ascx” in “default” folder

b. Modify first line not to include any information about code-behind files. The line should
looks like this at the end:
<%@ Control %>

c. Create layout of your skin by adding html and server controls; NB: you can use

VisualStudio's Designer to design the skin
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d. Repeat steps from a. to c. on ASCX control in “theme2” folder. NB: you can have
completely different layout of controls in two skins but it is important that you have the
same server controls in both skins (you can hide some server controls in one skin if you
want but the controls must be present anyway).

Part 2 - Generating Web Part
In Part 2, I'll cover the generation of Web Part class based on previously made skin. Here are the steps that

one could perform:

1. Download generator tool

a. Go to the codeplex project where generator tools is hosted
(http://www.codeplex.com/aspnetlibrary)

b. Go to "Releases” section and locate the latest release of
“ASPNETLibrary.SharePoint.WebParts" project

c¢. Download the “Generator.zip” from the “Files” section at the bottom of the page; NB: at
the time this article was written, the latest release was located at the following URL:
http://www.codeplex.com/aspnetlibrary/Release/ProjectReleases.aspx?Releaseld=10932




2. Setup the tool
a. Unpack downloaded archive to a folder on local disk; I unpacked it into “c:\Program
Files\swpgen\" folder
b. Add the tool's folder to PATH environment variable
i. Right click "My Computer” and select “Properties” menu item
ii. Go to advanced tab
iii. ~Click on “Environment Variables..."
iv. Locate “Path” variable in “System Variables” section
v. Modify it by appending the semicolon character and path to the folder holding
extracted archive; in my sample I added “;c:\Program Files\swpgen” to existing
value of "Path” environment variable.
3. Generate Web Part
a. Open command prompt and navigate to "default” folder in your Web Application’s project

b. You can optionally type and execute “swpgen” to see all the available options
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¢. Type next command to generate the Web Part:
swpgen /source:SampleWebPart.ascx /namespace:MyCompany.MyProject. WebParts

NB: the command above will generate a Web Part class called SampleWebPart in namespace
MyCompany.MyProject.WebParts.

Part 3 - Working on generated Web Part
In part 3, I'll show how generated class should be used and customized. Here are the steps that one could
perform:

1. Create Web Parts project
a. Go to your solution in VisualStudion
Right click on solution and select “Add” = “New Project...”
Choose “Class Library” in “Templates” section
Enter name for the project; I used "SampleWebParts” for the name in this sample
Click OK
Delete “Classl.cs” by right clicking it, selecting “"Delete” menu item and confirming that
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you want to permanently delete it

NB: You could also create a “Web Parts” project but I used a “Class Library” project in this sample as a more
general solution.

2. Add generated files to Web Parts project
a. Go to the folder where you generated Web Part’s class. In my sample it was
"C:\MyProjects\samples\SampleBaseSkinnedWebPart\SampleSkinns\default”



Copy both generated files to folder holding Class Library project you created in step 1.1In
my sample, it is a “c:\\MyProjects\samples\SampleBaseSkinnedWebPart\SampleWebParts"
folder and generated files are:

- "SampleWebPart.cs” and

- "SampleWebPart.generated.cs”
Go to VisualStudio and click on Class Library project (in my sample I clicked on
SampleWebParts project)
Select “Show All Files” option from Solution Explorer’s top menu as shown on next screen
shoot
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If you copied the files to the right folder then you will be able to see two generated files
under the SampleWebParts project node. Select them, right click on selection and choose
“Include in Project” menu item.

Turn off the “Show All Files” option

NB: instead of steps a. to f. you could right click on SampleWebParts project, choose “Add” = "Existing

Item...", navigate to generated files, select them both and include in project.

3. Add references to required assemblies

a.

In Solution Explorer, right-click the project, and then click Add Reference on the shortcut
menu

On the .NET tab of the Add Reference dialog box, select Windows SharePoint Services in
the list of components, and then click OK

Go to the codeplex project where generator tools is hosted
(http://www.codeplex.com/aspnetlibrary)

Go to "Releases” section and locate the latest release of
“ASPNETLibrary.SharePoint.WebParts" project

Download the “ASPNETLibrary.SharePoint.WebParts.zip” from the “Files” section at the
bottom of the page; NB: at the time this article was written, the latest release was located
at the following URL:
http://www.codeplex.com/aspnetlibrary/Release/ProjectReleases.aspx?Releaseld=10932

Open Windows Explorer, navigate to folder where solution file is and create a folder called
“ExternalReferences”. In my sample that is
“c\MyProjects\samples\SampleBaseSkinnedWebPart" folder

Extract the downloaded archive to "ExternalReferences” folder

Go to VisualStudio, right click on solution, choose “Add” - “New Solution Folder” and set
the name of solution folder to “ExternalReferences”

Right click “ExternalReferences” solution folder and choose “Add” “Existing Item..."
Navigate to “ExternalReferences” folder and choose
“"ASPNETLibrary.SharePoint.WebParts.dll"

Right click the Web Parts project (in my sample it is SampleWebParts project) and choose
“Add Reference...”



I. Click on “Browse" tab, navigate to "ExternalReference” folder and choose
“ASPNETLibrary.SharePoint.WebParts.dll"

m. Right click the Web Parts project (in my sample it is SampleWebParts project) and choose
"Add Reference..."

n. From the ".NET" tab select “System.Web" assembly

4. Add some code
a. Open SampleWebPart.cs from SampleWebParts project
b. Go to "Initialize” method and add next code:

this._newQuestion.Click += new EventHandler(NewQuestionClick);
this._submit.Click += new EventHandler(SubmitClick);
this._statusMessagePanel.Visible = false;

¢.  Add next two event handlers to SampleWebPart class:

void SubmitClick(object sender, EventArgs e)
{
this._statusMessagePanel.Visible = true;
this._submitQuestionPanel.Visible = false;

this._status.Text = "Your question was successfully submit.";

void NewQuestionClick(object sender, EventArgs e)
{
this._submitQuestionPanel.Visible = true;
this._statusMessagePanel.Visible = false;
}

5. Strongly sign the assembly
a. Right click SampleWebParts project and choose “Properties”
Go to Signing tab
Select "Sign the assembly” option
Open the drop down list and select “<New...>" item
Put a name of key file. I put SampleWebParts
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Deselect “Protect my key file with a password” option and click OK

Part 4 - Creating setup scripts and setup project

In part 4, I'll explain how setup scripts and setup project for deployment of Web Part should be made.
Follow next steps in order to make the setup scripts:

1. Create setup scripts
a. Go to SampleWebParts project, right click on it, choose “Add” > “New Folder” and name
it “Configuration”
b. Add three new files to the Configuration folder:



- SampleWebPart.dwp — a Text File
- manifestxml —a XML File
- setup.cmd —a Text File
c. Edit three files and set their content to be like the content of three files you can find in
accompanied sample solution. NB: you will need to modify the value of “Assembly” tag in
SampleWebPart.dwp and in manifest.xml for “SampleWebParts.dIl “ (to set the right
PublicKeyToken) and value of “url” parameter in setup.cmd (to URL of web site where you
want to deploy Web Part)
d. Select all three files, right click on selection, choose “Properties” and in “Build Action” drop
down choose “Content”
2. Create a setup project
a. Right click on solution and choose "Add” > “New Project...”
b. Expand "Other Project Types” node in “Project Types:” section and select “Setup and
Deployment” node
c. Select "CAB Project” project type in “Templates:” section (right side)
Type the name of the project and click OK (I entered SampleWebParts.Setup as name of
the project)
e. Right click on setup project you created in previous step and choose “Add” - "Project
Output”
f.  Select "SampleWebParts” in “Project:” drop down list
g. Select "Primary output” and “Content Files” by holding down the “Ctrl” key and clicking on

two items
h. Click OK
2]
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i.  Right click on setup project you created in previous step and choose “Add” > “File..."
j-  Navigate to “ExternalReferences” folder and select
"ASPNETLibrary.SharePoint.WebParts.dll" file

Part 5 -Web Part deployment
In part 5, I'll explain how the Web Part can be deployed to MOSS and how it should be configured to work

properly. You can follow next steps:

1. Deploy Web Part
a. Copy “setup.cmd” file from “Configuration” folder (in my sample it is
"C:\MyProjects\samples\SampleBaseSkinnedWebPart\SampleWebParts\Configuration\setu
p.cmd” file) into “Debug” folder of Setup project (in my sample it is
"C:\MyProjects\samples\SampleBaseSkinnedWebPart\SampleWebParts.Setup\Debug"”
folder)



b.

Execute “setup.cmd” to deploy Web Part to MOSS

NB: I would suggest you open a command prompt, navigate to “Debug” folder and execute
setup.cmd from command prompt so that you can see if deployment went fine
2. Setup MOSS web site

a.
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Open InternetExplorer and go to your MOSS web site (the one where you deployed Web
Part in previous step)
Select "Site Actions” > “Create”
Choose “Document Library” under the “Libraries” section
Set "Name” field to “Themes”
Click "Create”
In “Themes"” document library click on small arrow next to “New" button and then on
“New Folder”
Type “default” for name of folder and click OK
Repeat steps f. and g. and create a new folder called “theme2”
Default = Themes
Themes
Mew ~  Upload = Actions = 5
Type  Mame

[ default
[ themez

3. Upload skins

a.
b.

C.

d.

Go to "default” folder

Click on "Upload” button

Click on "Browse” button, navigate to skin in default folder (in my sample it is
“c\MyProjects\samples\SampleBaseSkinnedWebPart\SampleSkinns\default\
SampleWebPart.ascx” file), click “Open” and then “OK" to upload the skin (ASCX file) into
“default” folder in “Themes” document library

Repeat steps a. to c. by choosing “theme2” folder instead of “default” in all steps

4. Add Web Part to a page

a.

Go to a web page where you want to put your Web Part
Select "Site Actions” > “Edit Page”
Click on “Add a Web Part” button in section where you want web part to be added

e Shared Yersion of this page
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Find “Base Skinned Web Part Sample 1" under the “Miscellaneous” section
Select it by clicking on check box and click “Add”
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This web part will demonstrate the usage of BaseSkinnediebPart.

™ %] contact Details
Use to display detalls sboLk a contack For this pag or sike

1 [El ronkant Fditor Wah Part

Open “edit” menu for added Web Part and then select “Modify Shared Web Part” option



g the Shared Version of this page
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g. Go to "Skinned Web Part Settings” section and see how you can choose different theme
for your Web Part and different skin under the selected theme.

%14 Base Skinned Web Part Sam... x

+] Appearance
+ Layout
+| advanced

Skinned Web Part Skin Setti... kS
Select a theme: | default

Select o skin: [5]

h.  After you choose the preferred skin, click “OK" and then “Exit Edit Mode”
NB: you can try how the Web Part works if you click on “Submit” button in Web Part and then on
“New Question” button; it will not do anything special except to show/hide different panels but it
should be enough for demonstration.



Appendix A - Useful Links

Here are a few URLs that can be useful:

e http://www.codeplex.com/aspnetlibrary - project's home page at codeplex

e http://www.codeplex.com/aspnetlibrary/Release/ProjectReleases.aspx - a page that lists all the

latest releases
e http://www.codeplex.com/aspnetlibrary/Release/ProjectReleases.aspx?Releaseld=10932 — current

release at the time this article was made



